在Linux下联合ISE和第三方仿真工具进行仿真 ModelSim IUS VCS

chanra1n 2023-01-10 37
参考自Xilinx官方手册 - How do I compile Xilinx Simulation libraries for ModelSim Simulator ?    ANS: You can compile the libraries for MTI-SE,&nbs

Ubuntu22基于/etc/rc5.d/文件注册开机启动项实现Synopsys工具自动激活

chanra1n 2023-01-05 44
查看当前运行级别runlevel编写启动脚本vim /etc/init.d/autorun.sh写入内容#!/bin/sh /usr/local/eda_tools/synopsys/scl/2018.06/linux64/bin/lmgrd -c /usr/local/eda_tools/synopsys/Synopsys.dat赋予脚本执行权限chmod 777 /etc/init.d/autorun.sh将脚本链接到/etc/rc5.

Spyglass可用的feature,此处提供对应的src文件

chanra1n 2022-11-26 64
PACKAGE snps_lic_1 snpslmd 2019.2019 0 COMPONENTS="3D 3P " ck=0  PACKAGE snps_lic_2 snpslmd 2019.2019 0 COMPONENTS="A3200DX A42MX A500K A54SX 

在ISE9.2使用TMRTool工具进行三模冗余的方法

chanra1n 2022-11-13 135
高版本Linux安装ISE9.2出错的解决方法:因libstdc++.so.5丢失导致的ISE9.2等软件的安装问题以下内容来自网络,实测可以生成三模后的工程。一.ISE中跑综合,生成NGC文件首先利用ISE软件生成TMR所需的ngc文件。设置综合和实现的约束:综合设置如下图:(Pack I/O Registers into IOBs设置为No,记得与正常工程是不同的)。为了保证工程中没有分布式RAM(Distributed ram),HDL Options –RAM Style 改为block

解决在Linux高版本因libstdc++.so.5丢失导致的ISE9.2等软件的安装问题

chanra1n 2022-11-13 92
解决方法:wget http://mirrors.kernel.org/ubuntu/pool/universe/g/gcc-3.3/libstdc++5_3.3.6-30ubuntu2_amd64.deb wget sudo apt-get install ./libstdc++5_3.3.6-30ubuntu2_amd64.deb然后就可以解决问题了

(原创)Ubuntu18+ 解决Verdi使用报错的问题 链接库缺失问题

chanra1n 2022-10-10 184
报错内容:sh: /usr/synopsys/verdi/Verdi_O-2018.09-SP2/etc/lib/libstdc++/LINUXAMD64/libtinfo.so.5: no version information available (required by sh)解决方法:sudo apt-get install libncurses5 -y sudo mv /usr/synopsys/verdi/Verdi_O-

(原创)Ubuntu18注册lmgrd服务,实现开机自启动 Synopsys工具

chanra1n 2022-10-10 105
首先进入服务文件夹cd /lib/systemd/system然后新建service文件sudo touch edatools.service然后编辑为以下内容,其中路径以实际为准:[Unit] Description=Synopsys tools active service After=network.target [Service] Type=forking ExecStart=/usr/synopsys/activ

(原创)解决X86_64运行DC时依赖库报错

chanra1n 2022-10-04 193
sudo ln -s /usr/lib/x86_64-linux-gnu/libtiff.so.5 /usr/lib/x86_64-linux-gnu/libtiff.so.3 sudo apt-get install libjpeg62 libmng-dev -y sudo ln -s /usr/lib/x86_64-linux-gnu/libmng.so.2 

(原创)解决X86_64使用Primetime时依赖库报错

chanra1n 2022-10-04 147
运行以下代码即可,注意,相关路径如果不一致,根据自己实际的修改。sudo apt-get install -y wget wget https://myfpga.cn/download/libraries/libpng12.so.0 sudo mkdir /usr/lib/x86_64-linux-gnu/ sudo mv libpng12.so.0 /usr/lib/x86_64-linu

(原创)使用基于WSL2的Ubuntu安装EDA工具 Synopsys2018 Leda PT VCS Verdi DVE FM SCL

chanra1n 2022-10-03 335
首先运行以下命令#!/bin/bash echo "本脚本仅支持root用户使用!" echo "请在EDA安装包所在文件夹运行本脚本!将在5秒后自动运行,如果不正确,请按Ctrl+C键退出!" sleep 5s echo "开始清理缓存..." rm -rf /tmp/install_eda.log echo "开始安装依赖..."